[Point Cloud] Changing color per point index problem

(3 posts) (2 voices)

Tags:

No tags yet.

  1. Cromfel

    veteran
    Joined: Apr '08
    Posts: 243

    Hello

    Im testing some things with the point clouds to change the point color according to value set in array, but for some reason the colors are not visible properly even if the output color of the VSL seems to be ok. The point of the attached file is to go through Green->Red according to the value between 0 to 100 in the array.

    Anyone got idea what could be wrong? (Ignore the nonsense coding and commenting, I suck donkey balls with using VSL)

    Attachments

    1. PointCloud-VSL.cmo (5.9 KB, 8 downloads) 3 years old
    WARNING: Files uploaded in the forums are not monitored by 3DVIA and therefore might contain content that is malicious or offensive. Download at your own risk
    Posted 3 years ago #
  2. Cromfel

    veteran
    Joined: Apr '08
    Posts: 243

    Here is the solution for the problem. Im sure there are some other ways, propably even easier, but this is working atleast.

    Attachments

    1. PointCloud-VSL_Solved.cmo (6.7 KB, 19 downloads) 3 years old
    WARNING: Files uploaded in the forums are not monitored by 3DVIA and therefore might contain content that is malicious or offensive. Download at your own risk
    Posted 3 years ago #
  3. soniab

    Studio/Virtools Guru
    Joined: Aug '09
    Posts: 99

    Hello,

    Another way is to replace "iCloud.SetPointColor(pointCount, dcol);" by "iCloud.SetPointColor(i, dcol);" to apply color on each cloudpoint.

    Posted 3 years ago #

Reply

You must log in to post.